Wistia - Issues purchasing and adjusting payment settings – Incident details

Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Issues purchasing and adjusting payment settings

Resolved
Operational
Started about 1 month agoLasted 6 days

Affected

Billing

Partial outage from 1:13 AM to 8:46 PM

Updates
  • Resolved
    Resolved

    Billing and payment functionality has been fully restored.

  • Identified
    Update

    We are continuing to work to restore full functionality to the payments method page. Other billing functionality has been restored.

  • Identified
    Update

    The Payment Methods page is no longer displaying errors, but it is temporarily not possible to change ACH credit transfer settings.

    We are continuing to work to restore full payment settings functionality.

  • Identified
    Update

    We've implemented a fix for purchasing.

    Users are continuing to receive errors when accessing the Payment Methods page in account settings, and we’re continuing to work on further fixes.

  • Identified
    Identified

    We're aware of users encountering error messages when purchasing or visiting the Payment Methods page in account settings. We've identified the cause of the errors and are implementing fixes.