Wistia - Support Currently Unavailable – Incident details
All systems operational
Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.
Support Currently Unavailable
Resolved
Operational
Started over 1 year agoLasted about 1 hour
Affected
wistia.com
Operational from 2:31 PM to 3:41 PM
Updates
Resolved
Resolved
This incident has been resolved.
Identified
Identified
Our chat support system is currently unavailable. Support requests are being received, but we are temporarily unable to reply.