Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

TLS 1.0/1.1 Deprecation for fast.wistia.com/fast.wistia.net

Completed
Scheduled for July 03, 2023 at 5:30 PM – 6:45 PM

Affected

Embeds
Updates
  • Completed
    July 03, 2023 at 6:45 PM
    Completed
    July 03, 2023 at 6:45 PM

    Maintenance has completed successfully.

  • In progress
    July 03, 2023 at 6:34 PM
    In progress
    July 03, 2023 at 6:34 PM

    Maintenance is now in progress.

  • Planned
    July 03, 2023 at 5:30 PM
    Planned
    July 03, 2023 at 5:30 PM

    As part of improving our security posture, we will be disabling the ability to connect to fast.wistia.com or fast.wistia.net using TLS 1.0/1.1 connections on July 3rd. These endpoints are used for loading video embed metadata required by our player to play videos embedded on webpages across the web. Most web browsers/operating systems/devices from 2014 forwards should be utilizing TLS 1.2/1.3 to connect and load Wistia embeds.