Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Application Maintenance

Completed
Scheduled for May 31, 2023 at 6:30 PM – 7:43 PM

Affects

App
Embeds
Soapbox
Edit
Live
Updates
  • Completed
    May 31, 2023 at 7:43 PM
    Completed
    May 31, 2023 at 7:43 PM

    Maintenance has completed successfully.

  • In progress
    May 31, 2023 at 6:36 PM
    In progress
    May 31, 2023 at 6:36 PM

    Maintenance is now in progress.

  • Planned
    May 31, 2023 at 6:30 PM
    Planned
    May 31, 2023 at 6:30 PM

    We will be performing application maintenance that will route all requests to the Wistia application via CloudFront. No downtime is expected. One notable change is that TLS traffic will be terminated with Amazon certificates instead of Let's Encrypt certificates for all traffic going to the Wistia application (including the Wistia API).