Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Resolved
Transactional e-mails may be delayed

Started
May 19, 2023 at 2:29 PM
Status
Resolved after 29 minutes

Impact

Partial outage
Affected
wistia.com
  • Resolved
    Resolved

    A fix has been implemented and account e-mails are now being delivered again. Users may still see some delays in delivery of previously-sent account e-mails; users may need to re-request password resets or stats exports.

  • Investigating
    Investigating

    We are currently investigating delays in sending account e-mails.