Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Resolved
Some channel episode thumbnails may fail to load

Started
May 15, 2023 at 4:20 PM
Status
Resolved after 14 minutes

Impact

Partial outage
Affected
Embeds
  • Resolved
    Resolved

    A fix has been identified and channel thumbnails are loading again. This incident has been resolved.

  • Investigating
    Investigating

    We're received reports that some channel episode thumbnails are failing to load. We are currently investigating this incident.