Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Application Maintenance

Completed
Scheduled for April 25, 2023 at 12:00 AM – 2:20 AM

Affects

App
Embeds
Stats
Uploads
Edit
Live
Updates
  • Completed
    April 25, 2023 at 2:20 AM
    Completed
    April 25, 2023 at 2:20 AM

    Maintenance has completed successfully.

  • In progress
    April 25, 2023 at 12:33 AM
    In progress
    April 25, 2023 at 12:33 AM

    Maintenance is in progress

  • Planned
    April 25, 2023 at 12:00 AM
    Planned
    April 25, 2023 at 12:00 AM

    We are planning for a scheduled maintenance during this time.