Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Application Maintenance

Completed
Scheduled for April 21, 2023 at 12:00 AM – 1:41 AM

Affects

App
Embeds
Stats
Uploads
Edit
Live
Updates
  • Completed
    April 21, 2023 at 1:41 AM
    Completed
    April 21, 2023 at 1:41 AM

    Maintenance has completed.

  • In progress
    April 21, 2023 at 12:00 AM
    In progress
    April 21, 2023 at 12:00 AM

    We're performing application maintenance to migrate the Wistia application to new cloud infrastructure. No downtime is expected during the maintenance period.