Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Resolved
Stats Processing Delays

Started
March 17, 2023 at 4:15 PM
Status
Resolved after about 1 hour

Impact

Degraded performance
Affected
Stats
  • Resolved
    Resolved

    This incident has been resolved.

  • Identified
    Identified

    There are currently some stats processing delays and a fix is in process.