Wistia Marketing Website Down
Incident Report for Wistia
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 10:08 EDT
Monitoring
We've put a fix in for why our marketing site went down - we're keeping an eye on it!
Posted Apr 07, 2021 - 09:36 EDT
Identified
We're investigating why our marketing website is currently down. Your videos and podcasts are still working great! If you're having trouble logging in you can head to https://auth.wistia.com/session/new or go straight to your wistia.com subdomain.
Posted Apr 07, 2021 - 09:27 EDT