Slow playback for some uncached videos
Incident Report for Wistia
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 17:23 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2019 - 17:14 EST
Investigating
We are currently investigating this issue.
Posted Nov 25, 2019 - 16:39 EST
This incident affected: Embeds.