Playback issues for some uncached videos
Incident Report for Wistia
Resolved
Starting at 10am ET on Friday, October 18, 2019, some uncached videos that were fetched over insecure connections ("http", or non-TLS) failed to play. We traced this to a change in our video delivery system and deployed a fix for it at approximately 9:30pm ET on Tuesday, October 22, 2019.

Videos fetched over a secure connection were not affected.

We are currently purging affected videos from our CDN cache and will update this message when that work has completed.

UPDATE (10/23 12:49pm ET): We have purged all affected videos from our CDN cache.
Posted Oct 18, 2019 - 10:00 EDT