Increased AWS Error Rates
Incident Report for Wistia
Resolved
Our metrics report that video playback is back to normal. We are still working off a processing queue that built up as a result of the outage, but new uploads should be processed with only a minor delay.
Posted 9 months ago. Feb 28, 2017 - 19:36 EST
Monitoring
It appears that Amazon has made some progress on addressing their issue, which has allowed us to begin addressing our end of the symptoms. Uploading, encoding, and delivery will be returning to normal shortly. Playback may take a bit longer to fully return to normal as our content delivery networks fetch things from origin (which is where Amazon's services are in our tech stack). We'll continue to monitor the situation.
Posted 9 months ago. Feb 28, 2017 - 17:05 EST
Investigating
As a result of increased error rates from Amazon Web Services (https://status.aws.amazon.com/) in the US-EAST-1 Region, some operations involving Wistia videos (specifically uploads, downloads and serving a small percentage of video asset delivery) may fail. Assets currently cached in the Content Delivery Networks that we use will be unaffected, though assets that are not cached may fail (this is estimated to be about 5-7% of videos at any given time).
Posted 9 months ago. Feb 28, 2017 - 13:11 EST