Stats API and stats pages unavailable
Incident Report for Wistia
Resolved
This incident has been resolved.
Posted Mar 19, 2020 - 20:56 EDT
Investigating
We are currently investigating this issue.
Posted Mar 19, 2020 - 20:30 EDT
This incident affected: App and Stats.