Stats Outage
Incident Report for Wistia
Resolved
This incident has been resolved.
Posted May 03, 2019 - 11:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 03, 2019 - 09:16 EDT
Investigating
We are currently investigating this issue.
Posted May 03, 2019 - 08:53 EDT
This incident affected: Stats.