Wistia Application Degraded Performance
Incident Report for Wistia
Resolved
The Wistia application is back to normal performance.
Posted 4 months ago. Aug 13, 2018 - 10:14 EDT
Investigating
The Wistia Application is experiencing degraded performance. We are investigating.
Posted 4 months ago. Aug 13, 2018 - 09:43 EDT
This incident affected: App.