Soapbox Chrome extension issue
Incident Report for Wistia
Postmortem

At about 2:45pm EST on September 25th we were made aware of an issue for some number of Soapbox users that a bug existed that caused them to be stuck in a loop during part of the welcome flow. Specifically this affected Soapbox users that did not have a preference saved in their version of Chrome that provided webcam and audio access to Soapbox (when we detect that being the case, we send you through the screens where the problem existed). Most commonly these users would be brand new to Soapbox.

At 6:30pm that day we released a temporary solution to mitigate the issue while working on a more permanent fix. After some further research it was determined the issue was borne from updated third party component being used in the welcome flow and were able to instrument a permanent fix. In addition to instrumenting the permanent fix, we have identified areas in our test cases that would have caught this and as such we have bolstered those tests.

Posted 2 months ago. Oct 04, 2018 - 17:29 EDT

Resolved
This incident has been resolved.
Posted 3 months ago. Sep 26, 2018 - 10:01 EDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Sep 25, 2018 - 19:05 EDT
Monitoring
We have deployed a potential fix for this issue and are investigating whether it is resolved for all affected users. If you have an open support ticket regarding this issue, please reach out and let us know whether you are able to record new videos again.
Posted 3 months ago. Sep 25, 2018 - 18:35 EDT
Update
We have implemented a fix for this issue and are preparing to roll it out.
Posted 3 months ago. Sep 25, 2018 - 18:21 EDT
Identified
We have reproduced this issue internally and are working on a fix for it.
Posted 3 months ago. Sep 25, 2018 - 17:47 EDT
Investigating
We are investigating an issue with the Soapbox Chrome extension where clicking on the extension button in Chrome incorrectly opens a first-time "welcome" survey, preventing users from recording new videos.
Posted 3 months ago. Sep 25, 2018 - 17:26 EDT
This incident affected: Soapbox.