Upload Failures
Incident Report for Wistia
Resolved
Uploads should now be in good standing—the upload failure issue has been resolved.
Posted 4 months ago. Jun 12, 2017 - 22:55 EDT
Investigating
We're currently investigating an influx of upload failures within the Wistia App.
Posted 4 months ago. Jun 12, 2017 - 22:33 EDT