Channel Analytics Unavailable
Incident Report for Wistia
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 20:41 EDT
Investigating
We're currently looking into why our channel analytics are unavailable. Your stats will be back soon, please hold on!
Posted Oct 30, 2020 - 19:50 EDT
This incident affected: Stats.