Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.
Analytics Database Maintenance
Completed
Scheduled for April 02, 2025 at 12:00 PM – 12:38 PM
Affects
Stats
Under maintenance from 12:00 PM to 12:38 PM
Updates
Completed
April 02, 2025 at 12:38 PM
Completed
April 02, 2025 at 12:38 PM
Maintenance has completed successfully.
In progress
April 02, 2025 at 12:00 PM
In progress
April 02, 2025 at 12:00 PM
Maintenance is now in progress
Planned
April 02, 2025 at 12:00 PM
Planned
April 02, 2025 at 12:00 PM
We are planning for a scheduled maintenance to our analytics database. Stats may be delayed during this time.