Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

App/Analytics Database Maintenance

Completed
Scheduled for February 25, 2024 at 3:30 PM – 4:57 PM

Affects

App
Stats
Updates
  • Completed
    February 25, 2024 at 4:57 PM
    Completed
    February 25, 2024 at 4:57 PM
    Maintenance has completed successfully.
  • In progress
    February 25, 2024 at 3:30 PM
    In progress
    February 25, 2024 at 3:30 PM

    We will be performing database upgrades and expect brief unavailability of the Wistia app login page and a few stats-specific pages during the scheduled maintenance period.