Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Intermittent Failures Adding Media to Editor or Choosing Recording Destinations

Resolved
Degraded performance
Started 5 months ago Lasted 30 minutes

Affected

App
Edit
Updates
  • Resolved
    Resolved

    Adding media to the editor, choosing recording destinations, and move/copy are all working properly again.

  • Monitoring
    Monitoring

    We implemented a fix and are seeing media selection for the editor, recordings, and move/copy working properly again. We will continue to monitor.

  • Identified
    Identified

    Some users may be encountering errors adding media to the editor or choosing a destination for their recordings. We've identified the issue and are currently implementing a fix.