Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Resolved
Connection issues to wistia.com

Started
May 01, 2023 at 4:15 PM
Status
Resolved after about 2 hours

Impact

Operational
Affected
App
  • Resolved

    This incident has been resolved.

  • Monitoring

    We implemented a fix and are currently monitoring the result.

  • Resolved

    This incident has been resolved.

  • Investigating

    We're investigating reports of users being unable to login or connect to Wistia.