Welcome to Wistia's home for real-time information and updates on our applications. Here you'll find live and historical data on system performance and metrics. If there are any service interruptions, a note will be posted here.

Resolved
Degraded performance for some downloads

Started
February 24, 2023 at 7:17 PM
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
App
  • Resolved
    February 24, 2023 at 9:25 PM

    This incident has been resolved.

  • Monitoring
    February 24, 2023 at 9:05 PM

    We have implemented a fix and are currently monitoring the results. All customers should be able to download media assets.

  • Identified
    February 24, 2023 at 7:23 PM

    We believe that we have identified the issue affecting downloads and are implementing a fix now. We will continue to monitor as it goes into effect.

  • Investigating
    February 24, 2023 at 7:17 PM

    We're investigating reports of failures when downloading some direct assets. The failures seem to be happening inconsistently at this time. Video playback does not appear to be affect, only direct downloads.